php verzió frissítés

Frissítsetek PHP 7.2-re!

A PHP 7.1 és korábbi verziók 2018. decemberétől már nem támogatottak, a 7.1-hez is csak biztonsági frissítések jelennek meg! PHP frissítés Debian 9-en.

 

Aki még nem frissítette a PHP-t 7.2-es, vagy 7.3-as verzióra az tegye meg minél előbb, mert a PHP 7.1 csak 2019. decemberéig van támogatva, december után már biztonsági frissítések se jelennek meg hozzá.

(PHP verziók életciklusa: www.php.net/supported-versions.php)

Bár a Debian 9 stabilon még a PHP 7.0.33-as verzió a támogatott, néhány egyszerű paranccsal frissíthetjük a legújabb PHP-ra a rendszert.

 

Frissítsük a csomagokat

apt update

apt upgrade

Add hozzá a csomag repo kulcsát

wget -q https://packages.sury.org/php/apt.gpg -O- | sudo apt-key add -

echo "deb https://packages.sury.org/php/ stretch main" | sudo tee /etc/apt/sources.list.d/php.list

Telepítsd az alábbi csomagokat

apt install ca-certificates apt-transport-https

Telepítsd a PHP 7.2 verziót 

apt install php7.2 php7.2-cli php7.2-common php7.2-opcache php7.2-curl php7.2-mbstring php7.2-mysql php7.2-zip php7.2-xml

Ellenőrizd a telepítést

php -v

 

 

Mennyire volt hasznos ez a bejegyzés?

Kattints egy csillagra az értékeléshez!

Átlagos értékelés / 5. Szavazatszám:

Hozzászólás

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük

Scroll to top